Technical Advisory: IOC Detect version 2.2.2 to address iSIGHT Partners ThreatScape API v1 End Of Life

Summary:
iSIGHT Partners ThreatScape, or iSIGHT, will be ending support for version 1 of its API at the end of this year, 2015. Migration to version 2 will require new credentials. Version 1 and version 2 credentials are not compatible.
  
Existing customers using IOC Detect and iSIGHT are all currently on version 1 as no version 2 support has been shipped by Tanium. At the start of 2016, these credentials will no longer work. Tanium plans to release a version of IOC Detect 2.2.2 specifically to add version 2 support and to drop version 1 support concurrently.
 
At this time, there are no expected changes to iSIGHT functionality within IOC Detect as the only impact to the current product is an enhanced authentication scheme that requires new credentials.
 
Affected Customers:
IOC Detect users who have configured the product to stream indicators from iSIGHT. Any applicable users should acquire new credentials from iSIGHT and plan to upgrade IOC Detect after receiving these credentials.
 
Solution:
As soon as possible, users are encouraged to reach out to their iSIGHT representative to receive updated credentials.
 
NOTE: Version 2 credentials will not work on versions before IOC Detect 2.2.2, and version 1 credentials will not work with IOC Detect 2.2.2. As noted above, version 1 credentials will cease to work after 2015 regardless of IOC Detect version.
 
Workaround:
It is required that customers that are using iSIGHT go through this update process when they move to IOC Detect 2.2.2.
 
Additional Information:
For more information on iSight ThreatScape API - http://www.isightpartners.com/products/threatscape-api-sdk/
For more documentation on the ThreatScape API - http://www.isightpartners.com/doc/sdk-bp-docs/#/
Have more questions? Submit a request